Which Internet browsers are supported for EdReady?

Follow

Our recommended browsers are Firefox and Chrome. Internet Explorer (IE) is also fine, though anything older than IE9 is not supported and will have usability issues. (Note that we have not had any browser-related issues outside of students on IE8.)

Have more questions? Submit a request

Comments

Powered by Zendesk